FruitLoop

Quickfire Rapid-i problem

Recommended Posts

FruitLoop    8

Hello.

 

I've bought a CM Storm Quickfire Rapid-i some months ago.

I really like the keyboard but yesterday one of the led lights died. :mellow:

 

I've had no problems while using the keyboard from the past few months (bought it on 13/08/2014) only yesterday I noticed that the "E" key led was off.

 

I've tried everything I could think of to fix it, but to now avail. I've turned the lighting on and off, changed profiles, changed brightness levels and even unplugged and plugged back the USB cable.

 

The led seems to be completely dead.

 

I am now a bit worried now. I'm afraid there might be more led failures in the future.

 

I know the led's tend to get dimmer and even die over time on mech boards... but one dead led on a brand new keyboard seems a little odd to me.

 

I'd like to know if there's a way that I could send CM the board so you guys can check it out.

I can take some pictures if you want.

 

Thanks.

 

P.S - The key works just fine, it's just the led that doesn't light up.

Share this post


Link to post
Share on other sites
world    84

Can you get in contact with support somehow? They would be the best to help you with replacing your keyboard.

Share this post


Link to post
Share on other sites
Dip    0

I bought two of rapid-i keyboards. Both have failed LED´s. And I have only had them for 3 weeks!!

 

I will return both to the store!!

Share this post


Link to post
Share on other sites
Pclinde    197

I bought two of rapid-i keyboards. Both have failed LED´s. And I have only had them for 3 weeks!!

 

I will return both to the store!!

Please do so. We are currently investigating it. (Manufacturing, soldering etc). I am really sorry for this Dip. :(

Share this post


Link to post
Share on other sites
Fareed Tham    2

Hello.

 

I've bought a CM Storm Quickfire Rapid-i some months ago.

I really like the keyboard but yesterday one of the led lights died. :mellow:

 

I've had no problems while using the keyboard from the past few months (bought it on 13/08/2014) only yesterday I noticed that the "E" key led was off.

 

I've tried everything I could think of to fix it, but to now avail. I've turned the lighting on and off, changed profiles, changed brightness levels and even unplugged and plugged back the USB cable.

 

The led seems to be completely dead.

 

I am now a bit worried now. I'm afraid there might be more led failures in the future.

 

I know the led's tend to get dimmer and even die over time on mech boards... but one dead led on a brand new keyboard seems a little odd to me.

 

I'd like to know if there's a way that I could send CM the board so you guys can check it out.

I can take some pictures if you want.

 

Thanks.

 

P.S - The key works just fine, it's just the led that doesn't light up.

I have the some problem too.

Left Shift and Space bar LED is not lit up !!  :(  

Please Help!!! :(  :(

post-96251-0-38858600-1419342374_thumb.jpg

  • Upvote 1

Share this post


Link to post
Share on other sites
Pclinde    197

I raise you nine failed LEDs (excluding the caps lock, prt sc and scr lk keys which are meant to be off)!

 

Time to RMA :(

 

Yes, request RMA please.

 

Cheers, Pim

Share this post


Link to post
Share on other sites

I bought my keyboard in August and within 2 weeks my first led had died (INS media key). I was annoyed but I thought that seeing as led failure rate is high it was bound to happen to someone. Then a while went by before 2 more led's broke (Backspace and Page Down). At this point I was starting to wonder about RMA as 3 led's down is not only annoying but unacceptable. Now my right side windows led has gone and I am for sure going to RMA this keyboard.

 

Other than this problem though, the Rapid-I is a great keyboard. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.