Pclinde

QuickFire Rapid-i New Firmware (V.119 - Fix Startup Problems)

Recommended Posts

Pclinde    197
17rc4l.png

 

Hello everyone,

 

I am very happy to announce Firmware v119. We have teamed up with motherboard manufacturers to solve the 'No Boot- startup problem'.

 

Download the latest Firmware today:

 

Version: Firmware V.119 (EU ISO layouts, 88 Keys)

 

Release Date 2014-12-04

Language English

File Size 1.32 MB

Description 88 keys; for language layouts of DE,FR,GR,IT,ND,SB,SP,TR,UK


 

Version: Firmware V.119 (US ANSI layouts, 87 keys)

 

Release Date 2014-12-04

Language Multi languages support

File Size 1.32 MB

Description 87 keys; for language layouts of AF,RU.TA,TC,US,UI,CZ,SK


 

Also I would like to thank everyone for reporting the problem. We really appreciate it! Now go go go! 'Update your QuickFire Rapid-i Disco board. :D

 

Cheers, Pim 

  • Upvote 3

Share this post


Link to post
Share on other sites
world    84

Is there a changelog for this firmware? (or is it just bugfix for the startup problem?)

Share this post


Link to post
Share on other sites
Pclinde    197

Is there a changelog for this firmware? (or is it just bugfix for the startup problem?)

No changelog. 'Just' a fix for the startup problem. ;)

Share this post


Link to post
Share on other sites
tolga9009    4

Thank you Pim for the great support!

 

I've flashed the firmware, replugged my keyboard and rebooted my PC around 20 times to force the issue, but I was unable to do so. So, it looks like this firmware update really fixed the issue! Big thanks to you and the developers!

 

Still, please give me 1 - 2 weeks to finally evaluate this firmware update. I have 2 more systems to test this on. After that, I will give my final statement and edit my Amazon.de review.

 

Again, big thanks Pim for internally reporting this issue several times and taking care of us!

 

Cheers,

Tolga

Share this post


Link to post
Share on other sites
Pclinde    197

Thank you Pim for the great support!

 

I've flashed the firmware, replugged my keyboard and rebooted my PC around 20 times to force the issue, but I was unable to do so. So, it looks like this firmware update really fixed the issue! Big thanks to you and the developers!

 

Still, please give me 1 - 2 weeks to finally evaluate this firmware update. I have 2 more systems to test this on. After that, I will give my final statement and edit my Amazon.de review.

 

Again, big thanks Pim for internally reporting this issue several times and taking care of us!

 

Cheers,

Tolga

Thanks for the kinds words! :D I have tested the Firmware on 2 Rapid-i's and I had no failure so far. :D

Share this post


Link to post
Share on other sites
Pack Man    1

FIX works for me. No problems on Asus Sabertooth 990fx r2.0 motherboard.

 

When I am using M1, M2, … profiles and want to switch back to MODE I press FN + MODE and it exits M1, M2,… but instead of returning to the MODE I was using before I started M1, M2,… it goes to the next MODE in line. Then I have to circle through all modes to get to the MODE I was on before I enabled Backlighting profile mode (M1, M2,…). Can you please do something about this? Is there a beather way to exit Backlighting profile mode?

 

Another (TO ME) logical way of exiting Backlighting profile mode (M1, M2,…) would be to press FN + M1, M2,… and IF Backlighting profile mode is ON then EXIT if not ENABLE.

  • Upvote 1

Share this post


Link to post
Share on other sites
Pclinde    197

FIX works for me. No problems on Asus Sabertooth 990fx r2.0 motherboard.

 

When I am using M1, M2, … profiles and want to switch back to MODE I press FN + MODE and it exits M1, M2,… but instead of returning to the MODE I was using before I started M1, M2,… it goes to the next MODE in line. Then I have to circle through all modes to get to the MODE I was on before I enabled Backlighting profile mode (M1, M2,…). Can you please do something about this? Is there a beather way to exit Backlighting profile mode?

 

Another (TO ME) logical way of exiting Backlighting profile mode (M1, M2,…) would be to press FN + M1, M2,… and IF Backlighting profile mode is ON then EXIT if not ENABLE.

Thanks for the feedback. I will check this. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.