Shane McCarty

All LEDs stopped working on Rapid-I

Recommended Posts

I've been using my the CM Storm Rapid-I for a few weeks with no issues.  Suddenly, starting yesterday, I'm not getting any life from any of the LED.  The keyboard types fine.  I've tried updating the firmware and switching the USB ports around, but no luck.  Is there anything else I could try?  My motherboard is on the most recent BIOS version.

Share this post


Link to post
Share on other sites
Pclinde    197

Have you tried pressing FN+F1. I know it's super basic but I have to ask :P

Indeed, haha. ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.