Recommended Posts

Creator    2

 

Nah, I think I'll return it to the store to get my money back. Gonna buy a new one, obviously not a CM. Since I brought to your attention that I'm not happy about two windows keys and no context-menu one you got out another model (XTi) with the same stupid layout. Time to switch brands. Probably Corsair as they listened to the user-base when they raved about that ugly new logo and changed it back to the cool old one. I like companies that listen to their customers.

I won't let the door hit me on my way out.

Share this post


Link to post
Share on other sites

Good evening,

My rapid-i is suffering a problem. Currently using Window 10. while i press once (single input), the outcome was duplicated (more than 1 outcome). I do get my driver updated to firmware 1.2.2 once and it become fine, but it return to abnormal /unusually as the problem come again after i restart my computer. i do believe the product is just fine with all the buttons but i could use it with duplicate outcome.

Share this post


Link to post
Share on other sites
Pclinde    197

Good evening,

My rapid-i is suffering a problem. Currently using Window 10. while i press once (single input), the outcome was duplicated (more than 1 outcome). I do get my driver updated to firmware 1.2.2 once and it become fine, but it return to abnormal /unusually as the problem come again after i restart my computer. i do believe the product is just fine with all the buttons but i could use it with duplicate outcome.

Press FN + F5 (it's probably the turbo-mode duplicating multiple keystrokes).

Share this post


Link to post
Share on other sites

Hello everyone,

I am very happy to announce Firmware v119. We have teamed up with motherboard manufacturers to solve the 'No Boot- startup problems'.

Download the latest Firmware today:

Version: Firmware V.119 (EU ISO layouts, 88 Keys)

Release Date 2014-12-04

Language English

File Size 1.32 MB

Description 88 keys; for language layouts of DE,FR,GR,IT,ND,SB,SP,TR,UK

Download http://assets.coolermaster.com/gaming/download/keyboards/quickfire-rapid-i/rapid-i-firmware-pack-v119-uk.zip

Version: Firmware V.119 (US ANSI layouts, 87 keys)

Release Date 2014-12-04

Language Multi languages support

File Size 1.32 MB

Description 87 keys; for language layouts of AF,RU.TA,TC,US,UI,CZ,SK

Download http://assets.coolermaster.com/gaming/download/keyboards/quickfire-rapid-i/rapid-i-firmware-pack-v119-us.zip

Also I would like to thank everyone for reporting the problem. We really appreciate it! Now go go go! 'Update your QuickFire Rapid-i Disco board. :D

Cheers, Pim

I just got the keyboard and it is not letting me install any firmware for it. When i try to, the 'Ok' i greyed out. Right now, it doesnt light up and none of the hotkeys work.

Share this post


Link to post
Share on other sites
Pclinde    197

I just got the keyboard and it is not letting me install any firmware for it. When i try to, the 'Ok' i greyed out. Right now, it doesnt light up and none of the hotkeys work.

Hi,

 

Have you tried a USB 2.0 port?

 

Cheers, Pim

Share this post


Link to post
Share on other sites
kartana    5

I thought the LED problem is fixed now? Two LEDs died just 2 days after I bought my Rapid-i this week. I contacted CM support but they told me to ask my retailer for a replacement. If they have the faulty ones it will most likely fail again though...

Share this post


Link to post
Share on other sites

What's the status on Rapid-I replacement stock? Recieved one for X-Mas and it has 4 dead led lights. I'd hate to send it for rma and wait months for a replacement. Love the board but the light situation is disappointing. My Quickfire TK has been going strong for 4+ years without a problem.

 

Edit 5.3.2016 -> Make that 6 dead led's. :(

Edited by Christopher Evans

Share this post


Link to post
Share on other sites
CM Bram    37

What's the status on Rapid-I replacement stock? Recieved one for X-Mas and it has 4 dead led lights. I'd hate to send it for rma and wait months for a replacement. Love the board but the light situation is disappointing. My Quickfire TK has been going strong for 4+ years without a problem.

 

Edit 5.3.2016 -> Make that 6 dead led's. :(

 

Depends on where you are located and where you bought it.. Please contact our support department and or return it to the point of purchase for replacement, thanks :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.