Recommended Posts

Pclinde    197

I mean do they must have light? Noticed that they are turned off or broken not so late.

Yes, depending on what LED mode or custom LED mode. :)

Share this post


Link to post
Share on other sites
Joms Taruc    1

Been using my rapid~i since january, a week ago or so the key "3" led isn't working. Some of the key response is not accurate like it was before. I've already contacted support about the issue and unfortunately they're not replying yet. I wanna know if it's possible to RMA this product, what are the odds of getting it replace? Since this is a common problem in this model, is there a way to replace this model to different model? If yes, is there a fee? I've also read that the RMA is kinda bad in coolermaster(usually take months). Is it possible to get the product on the same day i brought my keyboard to the store where i bought it? Hoping for some answers thanks

  • Upvote 1

Share this post


Link to post
Share on other sites
CREATER    0

same problem with LED failing. my page down key led is so dim. happened before 1 month using the KB.  :(

Seems to be often problem. Is it matter to mass return?

Share this post


Link to post
Share on other sites
Fire Star    0

I am having the same problem, when randomly an LED just stops working. My ESC X V and - Keys are all dark and don't come on, even when changing modes, it would be nice to be able to RMA the product or exchange it. This is an obvious design flaw and not consumer misuse.

Thanks and hopefully we can resolve this issue.

Share this post


Link to post
Share on other sites
Jan+    0

Hi,

 

I just got my new Rapid-i Keyboard and I'm wondering if there's any way to activate a FN-Key lock? Would be really useful.

 

regards

Jan

Share this post


Link to post
Share on other sites
Creator    2

My '8' key LED died after about 7 months of moderate usage (5-6 hrs per day). Or at least that's what I thought - after I removed the key cap it seems that the LED fires up but it's very dim. To top this fortunate incident up, the store I've purchased this KB from no longer has it on their stock.

Any chance to get that LED to work properly? Has anyone successfully replaced one of these LEDs?

Share this post


Link to post
Share on other sites
Pclinde    197

My '8' key LED died after about 7 months of moderate usage (5-6 hrs per day). Or at least that's what I thought - after I removed the key cap it seems that the LED fires up but it's very dim. To top this fortunate incident up, the store I've purchased this KB from no longer has it on their stock.

Any chance to get that LED to work properly? Has anyone successfully replaced one of these LEDs?

 

Hi, seems like it's broken, please RMA it: http://coolermaster.force.com/pkb/articles/en_US/FAQ/How-to-obtain-a-product-replacement-RMA/?l=en_US&fs=Search&pn=1

 

Hi,

 

I just got my new Rapid-i Keyboard and I'm wondering if there's any way to activate a FN-Key lock? Would be really useful.

 

regards

Jan

 

Hi Jan,

 

Sorry that's not possible / supported.

 

I am having the same problem, when randomly an LED just stops working. My ESC X V and - Keys are all dark and don't come on, even when changing modes, it would be nice to be able to RMA the product or exchange it. This is an obvious design flaw and not consumer misuse.

Thanks and hopefully we can resolve this issue.

 

Please RMA it: http://coolermaster.force.com/pkb/articles/en_US/FAQ/How-to-obtain-a-product-replacement-RMA/?l=en_US&fs=Search&pn=1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.