Ed_7

CM Silent Pro M700 - Problem with RMA Request

Recommended Posts

Ed_7    0

Hello,

 

I need to RMA my PSU, specifically the Silent Pro M700, and I'm having problems with the request. I already created a support ticket, and received a response telling me to follow this guide http://coolermaster.force.com/pkb/articles/en_US/FAQ/How-to-obtain-a-product-replacement-RMA/?l=en_US&fs=Search&pn=1

 

I got stuck in step 6 because there is no "RMA Request" button under my product. It is under warranty until 2018, so I don't know what could be the problem. I tried with Chrome and Firefox.

 

Thanks¡

post-94903-0-44562800-1414171741_thumb.jpg

Share this post


Link to post
Share on other sites
CM Patrick    34

Hello EdoAlf,

 

Did you fill out your profile information? Can you send me your ticket number?

 

Thank you

 

Respectfully,

Patrick
CMUSA Support

  • Upvote 1

Share this post


Link to post
Share on other sites
Ed_7    0

Hello Patrick,

 

My ticket number is 00050791. I'm receiving support from Felinni M (super nice and fast to answer by the way). A couple of minutes ago he said to me that the case + screenshot was sent to IT for reviewing. 

 

I filled my profile information earlier, but only the *required fields. I just filled it completely but the button is still missing.

 

Very thankful for any input you can provide Patrick

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.