Oblique

CM Storm Devastator Mouse

Recommended Posts

Oblique    0

Hello, I just bought the product two months ago (keyboard and mouse). The keyboard is nice but the mouse, it's LED on its body suddenly disappeared, and sometimes it's blinking like a light bulb dying......

see this image:
http://i.imgur.com/JXozWMr.jpg

 

 

These are the only part of the mouse which has LED light working properly.

 

see this image:

http://i.imgur.com/RduNes4.png

 

 

 

And so far, it looks like this:
http://i.imgur.com/C8UIrip.jpg

http://i.imgur.com/XiEegFR.jpg

 

 

I can still use the mouse just fine, it's just the LED light. And I was just kinda disappointed because it's not have been too long since I bought the product and it's already acting like this. Any ideas what's happening? or any suggestions/solutions to fix this?

 

 

Thanks in advance~

 

 

edit: I forgot to mention this: When I bought the product, two months ago, it was just fine, the mouse have all its LED lights working properly. I just can't remember when it became like this.

Share this post


Link to post
Share on other sites
Oblique    0

I tried moving it to a different USB ports (My PC have 8 USB ports total), and I also tried plugging it in a different computer and laptop, but it's still the same. 

This might be out of the topic but I also updated my drivers but no luck.

 

And I bought the product in a registered PC repair shop, not exactly a CM store, and they only have 1 WEEK product warranty for it, and it's been already a month, sadly. But on the CM manual (quick start guide) inside the packaging, it says 2 YEARS warranty.

 

I live in Philippines (PH) by the way.

Share this post


Link to post
Share on other sites
Pclinde    197

I tried moving it to a different USB ports (My PC have 8 USB ports total), and I also tried plugging it in a different computer and laptop, but it's still the same. 

This might be out of the topic but I also updated my drivers but no luck.

 

And I bought the product in a registered PC repair shop, not exactly a CM store, and they only have 1 WEEK product warranty for it, and it's been already a month, sadly. But on the CM manual (quick start guide) inside the packaging, it says 2 YEARS warranty.

 

I live in Philippines (PH) by the way.

The LED is probably broken. :(

 

Like World suggested: submit a ticket. https://account.coolermaster.com/

 

Cheers, Pim

Share this post


Link to post
Share on other sites
Pclinde    197

Is that so :(

I just submitted a ticket recently. Thanks for the help~

No problem! Good luck, if I can help you out with anything else, let me know. ;)

Share this post


Link to post
Share on other sites
world    84

Hello, i have the opposite. My leds is glowing all the time. even when i have turned of my computer. Should it do that?

 

Depending on the motherboard, your computer might just have power being output through the USB port even when the computer is off. You might be able to find a setting in your computer that shuts off USB power when the system is off though.

Share this post


Link to post
Share on other sites
Ion Silviu    0

I bought this combo on the 1st of December (5 days ago). The keyboard is amazing and i love it but the mouse's scroll wheel, when scrolling down, will often scroll one "tick" up. I've changed computers, uninstalled the auto-driver in the device manager, changed the number of ticks my mouse scrolls in the control panel, turned off smooth scrolling in my browser, etc etc.

 

Nothing.

 

I've submitted a ticket but I am so angry about this that I still need to vent. :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.