hamnivlem

Quickfire Rapid-i (brown), some keys not lighted up

Recommended Posts

hamnivlem    0

First off, this is a great product. I love the overall build of the keyboard.

 

Okay, now for my problem.

 

Keyboard was fine for a month or so, until lately, some keys are not lighted up even with the mode where all lights are turned on.

 

Namely.. F3, F4, Q, W, Prt Sc, Scr Lk, Page up, Y, 8, C, V, left Alt, down arrow and a few others.

 

Could this be a macro/customization function or something where what I did was manually turned off some switches? If so, how do I reset it. Alternatively, how do I troubleshoot this.

 

Please help, thanks. Keyboard is only two months old, it worked fine weeks before.

Share this post


Link to post
Share on other sites
world    84

If you want to do a bit of troubleshooting, try using the keyboard with another computer and see if the problem keys light up there. Also, the keys that you listed do not light up no matter what mode the lighting is in?

 

Also, is your rapid-i updated to the latest firmware?

 

I would recommend contacting support for this though, since it sounds like there might be something wrong with the keyboard beyond just a settings problem, especially if you try connecting it to another computer and it still doesn't work properly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.