big_iceman

Need Help! CM 690 III - Top fan won't fit!

Recommended Posts

big_iceman    1

Hi,

 

So I just bought the CM 690 III case for my new rig. While putting it together I realized that the Cooler Master MegaFlow 200mm fan I bought won't screw on the top section of the case. It fits in alright but there are no screws that can hold it in the space given. The holes are relative bigger than the screws.

 

Considering the fact that the one I got is a transparent side window one, that 200mm would prove to be completely useless if it cannot be mounted on the top.

 

It clearly mentions on the website as well as the packing box that it can support a 200mm top fan but I just do see how that's possible. Anyone with a CM 690 III who could help me or was this just a marketing gimmick by CM?

 

I hoping to be proved wrong and that someone will be able to come up with a way or guide me with it. Thanks

 

Some pictures illustrating my issue.

 

Here is what it looks like without the top panel. 
2lc06it.jpg
 
Here is the 200mm fan place underneath it, supported with my hand for the purpose of this picture.
2jfaxzt.jpg

Share this post


Link to post
Share on other sites
world    84

I don't have a CM690III, so I can't tell you from experience, but I did a quick search on Google and here is what a user on tomshardware said about it:

 

In case anyone else wants to know, I found the answer. It turns out the whole top of the case could be removed by releasing some clips. Doing that revealed screw holes for a 200mm fan.

Share this post


Link to post
Share on other sites
Kevin Voong    0

Hi big_iceman,

 

Welcome to the community. The instruction for this installation can be found starting on page 13 of the manual. You will need to remove the top 2 panels, once removed you will be able to view the mounting holes for the fan.

 

Instructions can also be found on our knowledge base.

http://coolermaster.force.com/pkb/articles/en_US/FAQ/Install-200mm-Fan-to-Top-Fan-Slot-of-CM-690-III-Case/

Share this post


Link to post
Share on other sites
big_iceman    1

I don't have a CM690III, so I can't tell you from experience, but I did a quick search on Google and here is what a user on tomshardware said about it:

 

 

Hi big_iceman,

 

Welcome to the community. The instruction for this installation can be found starting on page 13 of the manual. You will need to remove the top 2 panels, once removed you will be able to view the mounting holes for the fan.

 

Instructions can also be found on our knowledge base.

http://coolermaster.force.com/pkb/articles/en_US/FAQ/Install-200mm-Fan-to-Top-Fan-Slot-of-CM-690-III-Case/

 

 

Thank you. That helped me out. Perfect. My rig is all set. Thanks alot again.

  • Upvote 1

Share this post


Link to post
Share on other sites
abdoo    0

Hi big_iceman,

 

Welcome to the community. The instruction for this installation can be found starting on page 13 of the manual. You will need to remove the top 2 panels, once removed you will be able to view the mounting holes for the fan.

 

Instructions can also be found on our knowledge base.

http://coolermaster.force.com/pkb/articles/en_US/FAQ/Install-200mm-Fan-to-Top-Fan-Slot-of-CM-690-III-Case/

http://prntscr.com/a9lbb6

should i but nails in red or blue places?

Edited by abdoo

Share this post


Link to post
Share on other sites
deepblue    0

Hi everyone,

 

I just purchased several JetFlo fans to replace all stock fans in my rig. I replaced the front MegaFlow 200mm by 2xJetFlo fans. I think it would be better if I place the MegaFlow on the top instead of 2 fans 120mm. The problem starts here. The stock MegaFlow come with the case does not have screw thread in all 8 screw holes. It's supposed to have that in any fan I have ever seen. That's why I cannot mount the stock MegaFlow on the top. I see this fan can be mounted at the front by using 4 long stand-off, but these long stand-off screws cannot be used on the top because the hole does not fit. It looks like this stock fan cannot be swapped to another position.

 

I can workaround by using loop tie but it's always nicer to fix by screw. Could any of you help me? Or am I missing something? Is the MegaFlow retail version different than the stock one?

 

Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.