Amos Ng Jin Hao

CMStorm Mech Audio and Mic Jacks not working

Recommended Posts

Hi all,

 

I've had the keyboard for awhile now. Just got a new headset that has the 3.5mm jacks for mic and audio. I plugged them in, installed the driver, but I still get no sound. The PnP USB sound device shows up on my Sound settings when I plug it in, and it shows the levels going up and down when I'm playing music, but the headset itself is receiving no sound.

 

I plugged the headset directly into my computer and it works perfectly, so it's not a problem with the headset. 

 

The keyboard is currently plugged into a USB 3.0 port in my computer.

 

Any clues would help a lot.
 
Thanks for the kind help.
 
 

 

Share this post


Link to post
Share on other sites
world    84

Hmm, if it works on your friend's laptop, then some settings might not be right on your computer :(

Share this post


Link to post
Share on other sites
world    84

Just a quick check, but is the default sound device set to the correct one? (In both the windows control panel as well as the music program you're using)

Share this post


Link to post
Share on other sites

Yep. USB PnP Device it says. When I unplug the headset from the keyboard it disappears, so I'm absolutely positive USB PnP Device means the keyboard's jack. The levels go up and down as well, but no sound comes out of the headset. As I mentioned before, the headset works on other laptops or if I plug it in directly to my computer, so it isn't a problem with the headset.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.