Hyperkeratosin

CM Trooper Fan LED Toggle Not Working

Recommended Posts

I recently purchased a CM Trooper (Rev 2)  and installation went fine, no problems. All of the buttions on the top pannel work except for the fan LED toggle. I've tried every different configuration of wires and tripple checked all connections. The LED toggle buttion beeps when pushed but does no toggle the LEDs. Any suggestions?

 

Specs:(If you need them)

 

Motherboard: MSI Mpower Max AC

RAM: Patriot Viper Xtreme 16GB (2x8GB)

Power Supply: Corsair CX Series 750 Watt ATX/EPS Modular 80 PLUS

CPU: Intel i7 4770K 3.5 GHz

Hard Drive: 1 TB Desktop Hard Drive: 3.5 Inch, 7200 RPM, SATA 6 Gb/s, 64 MB Cache

Share this post


Link to post
Share on other sites

Hi Hyperkeratosin,

 

First off grats on your new case (I like this version better than the last one because of the windowed panels).  In regards to your situation, it may be that the plastic panel on the top is stuck in some manner or it could be the switch is stiff/stuck as well.  Remove the top panel from the case and you should have access to the switches themselves (to remove the panel, remove both side panels, then along the inner top of the case, there are 3 clamps on each side that you need to release).  Check the led switch and verify it works.  If it does, you may just need to press the button on the top panel a bit to make it reach that switch.  If the switch doesn't work period, please let us know.

 

Where are you located?

  • Upvote 1

Share this post


Link to post
Share on other sites

 Dear neverXmiss, thank you for the advice and I did as you requested. I lifted the top panel off and checked the LEDs as well as the button. The LEDs were working and all the wire connections were secure. I pushed the LED toggle button down pretty hard, but to no avail. It simply would not work, no matter how hard I pushed. Is there a way to fix this or should I get a replacement top panel? Also, I put my location on my profile if you need it. 

 

Thank you.

Share this post


Link to post
Share on other sites

Understood.  It sounds like the panel itself is mechanically faulty.  We can definitely help out.  Please file a part request for the panel here:

http://www.coolermaster-usa.com/partrequest.php

 

For the type select Case, for model, select SGC-5000W-KWN1, then select I/o panel or usb panel for the part.  The rest of the form is shipping information you need to fill out.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you for your help. Cooler Master has the best customer support I have ever seen! You guys are very helpful and I wish every company was as good as you!

 

I have filled out a part request and sent it. Thank you very much!

Share this post


Link to post
Share on other sites

Hey, I`m having the same problem with my CM Storm Stryker. The power button, USB`s and jack`s are working perfectly. I removed the top cover to check the HDD LED, that was working fine. No LED and no fans are working (except the HDD LED). I have tripple checked all cables and connectors. Should i just replace the top panel? and does CM cover this in the warranty? 

 

Specs:

 

Intel i7 5820k 3.3Ghz

MSI X99i

Windforce GTX 970 4GB

Share this post


Link to post
Share on other sites
knud    129

Yeah, a new I/O panel will fix it. Contact CM support and they can help you out.

Share this post


Link to post
Share on other sites
HookedonHD    0

I know this is an old thread. However, recently I noticed the LED fan button on my CM Storm Styrker is not working and when I push it I hear beeps. The LED's are constantly on and they won't turn off. I am redoing the wiring right now and I don't see anything out of the ordinary. I looked at the manual but I can't find anything related. Thanks in advance!

20200403_093902[1].jpg

20200403_093912[1].jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.