CM Jerry

[Official] Nepton Owner's Club

Recommended Posts

kikoandr0id    0

hi guys, quick question: i have the nepton 140XL, and i was wandering how is the orientation of the jetflo fans in order to be the push - pull configuration? both fans have a cooler master logo and on the other side there is the technical sticker. so how should the sticker / logo on both fans  on either side of the radiator should be to get a push - pull configuration? 

Share this post


Link to post
Share on other sites

Help my motherboard only has 1 CPU fan header and one 4 pin case fan header..... I just got the cooler master 280l.

Question: "Should i connect the pump OR the fans to the CPU fan header". Thanks in advance for the help

Share this post


Link to post
Share on other sites
kikoandr0id    0

the pump should be connected on the cpu fan header. the fans go on the 4pin header (pwm) in order to controll the fan speed.

Share this post


Link to post
Share on other sites
Razor2014    0

Hi, does anyone know if the Nepton 280L that is currently out, is the new revised version?  I talked to Cooler Master twice on the phone and they knew nothing about it.  Thanks!

Share this post


Link to post
Share on other sites

Ok thanks for the answer. I thought the CPU fan header controlls the speed of the fan and the system fan header runs at full speed since the fans sound like a helicopter taking of when plugged into it.... Maybe i have to change in the BIOS from "CPU smart mode (auto) to PWM... Any further ideas? Just as a refference my motherboard is a Gigabyte x58a-ud3r

Share this post


Link to post
Share on other sites
kikoandr0id    0

no, the cpu fan header in your case controls the pump. and yes, you should switch from smart mode to pwm to enjoy the full glory of the cooler :)

Share this post


Link to post
Share on other sites
Bjorn Haman    0

Hi CM and members.

 

I have a problem with my Nepton 140 XL and have localized the problem. Maybe someone can help me out here.

 

- I have just installed my Nepton 140 XL onto an ASUS Gene VII MB and the cooler makes a TERRIBLE piercing sound.

- I have connected the cooler to CPU_FAN and the two fans to CPU_OPT

 

If I go into ASUS ROG BIOS and switch PWM to DC (on the CPU_FAN), the sound stops, and if I switch back it immedietly start screaming again. 

 

Can I connect it in another way. I assume I want PWM turned on, but it is impossible with the high sound. 

 

Any thoughts? 

 

Thanks.

/Bjorn

Share this post


Link to post
Share on other sites
ColdAzIce    0

I would love to provide you with some feedback as to the performance of this cooler.

 

BUT, my 280L only came with 1 INTEL bracket for the CPU block and useless.  :(

 

Does CM replace missing parts in North America only, or in Europe as well?

Share this post


Link to post
Share on other sites

Hi guys, first post.  I want to get the Nepton 280L but I'm wondering if it will fit in the CM Storm Trooper with an ASRock Z97 Exteme 6?  I obviously want to mount it in the top of the case, I'm just wondering if the clearances will be good.  I want this cooler to use on my i7-4790K.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now