CM Nick C

Official V series PSU Club

Recommended Posts

StevenTB    0

Yeah, it's really weird. I've uploaded a video of it. Hopefully someone here can figure it out.

Any further developments Kai Zen Chong? I just got a v550 a few days ago and am having the same sort of issue, though not quite as loud, it still buzzes if switched on or off. I logged an rma yesterday. I don't want to use the PSU just incase, but I also don't want to be without a pc for a great length of time.

Edit : While i was here typing CM updated my RMA ticket and have remedied the issue at hand. I am to get it replaced at the store I picked it up from, who didn't want to help me in the first place, but hopefully with CMs blessing it will go ahead.

Share this post


Link to post
Share on other sites

I bought the V850 two months ago. It's been working fine until yesterday; it' s dead. I started a RMA and will report back on the process. Very disappointing at this price point. 

 

Update: It's been 5 days since my faulty PSU was delivered to Cooler Master. No movement or ETA on when it will be process. The RMA case status still shows "Return Product".

Share this post


Link to post
Share on other sites
Mohd Noh    179

I bought the V850 two months ago. It's been working fine until yesterday; it' s dead. I started a RMA and will report back on the process. Very disappointing at this price point. 

 

Update: It's been 5 days since my faulty PSU was delivered to Cooler Master. No movement or ETA on when it will be process. The RMA case status still shows "Return Product".

Hi kai

 

My suggestion try contact our support services via email or phone ... might they can help you ....

Share this post


Link to post
Share on other sites

Looks like higher end CM power supply are having QC issues. Non of my entry level PSU fails on me before except 1 that been using for 5 years. That failed is mainly due to over used(7/24) and it can't supply enough power.

Share this post


Link to post
Share on other sites
vx229h    0

my CM v750 ( semi mod ) also has same BUZZING noise after 2/3 months of use.....got a v750 ( full modular ) as replacement resulting same issue from the very first day .....again got a new v750 (full modular ) and again result is same  -______________-  ....now they are offering me a v850 ........ -_- 

Share this post


Link to post
Share on other sites
Bruno Melo    0

Hi,

( Quoting my topic:  Topic Link )

 

My Silent Pro M700 blew up because external power surge. Now I need to replace it and since that lineage no longer exists, I’m not sure about which one I should choose?

I was looking towards the V750, but I realized it is smaller and uses a 120mm fan unlike my Silent Pro.

So my question is, do you guys know if the new V750 will make more noise than my old Silent Pro M700?

Or should I go for the V850, that also have a 135mm fan, and also more expensive?

Also, reading these last issues about buzzing, I'm concerned with that...

Thanks!

Share this post


Link to post
Share on other sites
Neziak    0

Hi all, just wanted to update on my V750 buzzing issue. After posting on this forum, a CM rep got in touch with me and directed me to the local distributor for RMA. They initially thought they could provide a replacement immediately but after testing several units in their stock, they found their entire batch of stock were faulty. After some days of waiting for new stock to arrive, got a replacement unit which has been working well since.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now