Search the Community

Showing results for tags 'tx3 evo'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Campaign
    • Case Mod World Series 2019
  • Announcements and Giveaways
    • Announcements
    • Giveaways
    • CES & Computex
  • PC Building Guide
    • Reviews and Unboxing
    • Build Advice
    • Build Worklogs
  • Hardware
    • Cooling
    • Cases
    • Power Supplies
    • Peripherals
  • General Discussion
    • General Hardware
    • Overclocking
    • Game Zone
    • Product Suggestions
  • Modding
    • Mod Lounge
    • Mod Worklogs
    • Mod Contests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Hey everybody, so I bought a TX3 evo cooler and I followed all the instructions but when it came down to installing it, as soon as the pins on it's one side would mount the pins on it's other side wouldn't, even using extreme force. I tried installing both inside the case and outside and I also tried the screw configuration for other types of CPUs (I have an i5 8400) but it still wouldn't mount. Could it be defective or am I doing something wrong? All the youtube videos I saw on TX3 installations either leave the mounting part out or make it look easy.
  2. Hi. I have a Cooler Master Hyper TX3 EVO Cooler CPU. It has always worked well but now it makes a lot of noise. I have not seen any screws to open it, I've tried to open it by pulling it but it's so hard it looks like it will break. How to open the fan to lubricate it? Excuse my English.