Search the Community

Showing results for tags 'rapid-i'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Campaign
    • Case Mod World Series 2019
  • Announcements and Giveaways
    • Announcements
    • Giveaways
    • CES & Computex
  • PC Building Guide
    • Reviews and Unboxing
    • Build Advice
    • Build Worklogs
  • Hardware
    • Cooling
    • Cases
    • Power Supplies
    • Peripherals
  • General Discussion
    • General Hardware
    • Overclocking
    • Game Zone
    • Product Suggestions
  • Modding
    • Mod Lounge
    • Mod Worklogs
    • Mod Contests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 5 results

  1. WINDOWS 7, 8 & 8.1 > QuickFire Rapid-i doesn't start on boot Note: BIOS settings, options and choice of words can be different. Test platform: GA-Z97X-SOC Force (Z97 - LGA1150 - H3) + i7 4790K - BIOS Settings: Optimized Defaults. Please ensure that you have enabled USB legacy or USB legacy devices in the BIOS. Try connecting the Rapid-i to a different USB port (both USB 2.0 and 3.0). Make sure you reboot the computer or laptop for test purpose. Uninstall Intel® USB 3.0 eXtensible Host Controller Driver (also known as Intel USB 3.0 Driver). You can verify that uninstallation is complete if the computer or laptop starts searching for available USB devices. Make sure you reboot the computer or laptop after this process. Some devices might not work after a reboot, replug the USB connector(s). If all devices are set, shut down the computer or laptop. Now boot the computer or laptop (hopefully the Rapid-i boots succesfully now). Note: USB 3.0 devices might be operating at a Lower Speed. [under construction- Testing]
  2. Hello everyone, I am very happy to announce Firmware v119. We have teamed up with motherboard manufacturers to solve the 'No Boot- startup problem'. Download the latest Firmware today: Version: Firmware V.119 (EU ISO layouts, 88 Keys) Release Date 2014-12-04 Language English File Size 1.32 MB Description 88 keys; for language layouts of DE,FR,GR,IT,ND,SB,SP,TR,UK Download http://assets.cooler...ack-v119-uk.zip Version: Firmware V.119 (US ANSI layouts, 87 keys) Release Date 2014-12-04 Language Multi languages support File Size 1.32 MB Description 87 keys; for language layouts of AF,RU.TA,TC,US,UI,CZ,SK Download http://assets.cooler...ack-v119-us.zip Also I would like to thank everyone for reporting the problem. We really appreciate it! Now go go go! 'Update your QuickFire Rapid-i Disco board. Cheers, Pim
  3. Is there a firmware for the QuickFire Rapid-i Model SGK-4040-GKCL1-SP (Spanish Layouts) keyboard? Thk!
  4. Hello, I joined the forum because I hear it's the best way to get support from CM, and their customer service is the first I've called that asked me to leave a message (?) rather than putting me through to a rep hahaha I got a Quickfire Rapid-i keyboard for my birthday almost two years back. I have kept this keyboard in a desk with a sliding-drawer compartment to keep debris and dust off of it, used it very gently for a gaming keyboard, and in return it has served me faithfully with high functionality and cool-a-f light patterns. Last night, however, I somehow honked up everything. I was homeless for a while and hadn't used the keyboard in ages. It wasn't until just yesterday that I could finally hook up my rig again in comfort. I had forgotten the key combination to change the light pattern, and genius that I am, I thought I'd just keep guessing rather than look it up. I ended up locking the keyboard into function mode due to holding the FN key down too long in my deliberation. Only issue was, it wouldn't get out of function mode through the method listed in the user guide. Only one key would light at a time, and it had to be F9-F12. All the letter keys were typing crazy duplicates--if I gently tapped "a", I would see "aaaaaaaaaaaaaaaaaaa" appear at about the speed of light. I was able to get the lights working properly again through methods as stupid as those I messed up with (keysmash until victory), but the duplicate key issue persists. I can't find a single result for this problem online. I know the keyboard isn't dirty, it's up-to-date to my knowledge, I have NEVER spilled liquid in it...I don't know how to fix the problem. I can't game or even log in under these conditions! All I wanted was to play Goat Simulator after work sob sob Any help or advice would be very greatly appreciated! Thanks, -Septima
  5. Hey Guys! I recently bought a CM Rapid-i TKL keyboard and i use it primarily on my desktop computer which runs windows/linux. I would also like to use it on my Macbook but would like to swap the alt key with the super key both physically on the keyboard and within the software. Any idea how i can reprogram those 2 keys and have it be persistent across all my Operating Systems? Thank you