Search the Community

Showing results for tags 'pump noise'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Campaign
    • Case Mod World Series 2019
  • Announcements and Giveaways
    • Announcements
    • Giveaways
    • CES & Computex
  • PC Building Guide
    • Reviews and Unboxing
    • Build Advice
    • Build Worklogs
  • Hardware
    • Cooling
    • Cases
    • Power Supplies
    • Peripherals
  • General Discussion
    • General Hardware
    • Overclocking
    • Game Zone
    • Product Suggestions
  • Modding
    • Mod Lounge
    • Mod Worklogs
    • Mod Contests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Bought my liquid cooler a year ago. It started making noise other than that of air being stuck. The pump sounds more like a the pump is giving up i guess. If anyone knows about this do help me
  2. Hi Guys I've installed the Cooler Master liquid 120 just 2 months ago and a few days ago the pump started to make a strange noise, everything works properly, I have a I7 4790K and the idle temperature is 30 ° C, I just wanted to check if it was all normal, the strange fact is that I'm sure it did not make any weird noise before, the pump is connected to a 4 cpu fan pin. I will soon post a video for more clarity, thanks in advance: D