Search the Community

Showing results for tags 'psu'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Case Mod World Series 2017
    • Case Mod World Series 2017
  • Announcements and Giveaways
    • Announcements
    • Giveaways
    • CES & Computex
  • PC Building Guide
    • Reviews and Unboxing
    • Build Advice
    • Build Worklogs
  • Hardware
    • Cooling
    • Cases
    • Power Supplies
    • Peripherals
  • General Discussion
    • General Hardware
    • Overclocking
    • Game Zone
    • Product Suggestions
  • Modding
    • Mod Lounge
    • Mod Worklogs
    • Mod Contests

Calendars

  • Community Calendar

Found 18 results

  1. I just got my MasterWatt Maker 1200 MIJ PSU a few days ago. However, I can tell that it has significant electrical noise and some time with popping/buzzing noise when the power cable is plug in both with and without the power switch on. I tried to take it out from my PC case and without other components connected. But still no luck at all. What causes it? Any idea? Sorry for my bad English. By the way. The noise seems not like continuously but more like Intermittent.
  2. Hi. I'm looking to build a pc for my folks (no graphics card) and they would like to keep it small so I will be using the 110 case. Which PSU should I use with it? I was thinking of a modular one since its a small space, but I don't need much power since there is no gfx card, only onboard graphics. Also I keep reading stuff about inverting the PSU to exhaust air since there is only one fan in the case, the front intake. The build is simple: core-13 with Intel stock cooler fan, 1 M2 NVME SSD drive, two sticks of DDR4 Ram and a Gigabyte MiniITX m/b. So, PSU recommendations?
  3. My PC turned off randomly the other day. The power cable going into the PSU had been slowly pulling out and I guess it pulled out too far that it shut down. I pushed it back in and tried turning on my PC, but it turned off immediately after turning on (fans spun, lights flicked on for a second). I played with the internal cablings of my PC but the problem still occurred. So I've taken the PSU completely out of my PC and tried turning it on manually by following this tutorial https://www.howtogeek.com/172933/how-can-i-test-my-computers-power-supply/ . The PSU's fan turns on for a second then turns off, so I've limited the problem to the PSU hence why I'm on this forum. Anyone able to help or give any advice?
  4. Hello guys, I was a happy user of a Silent Pro M2 620W PSU for almost 4 years, until a couple days ago it refused to turn on my PC. I decided to RMA it, but I realised that there is a spot with scratched paint at one edge and the sticker has two scratches. Shipping cost is not insignificant, so I wonder if these scratches are enough to cause the rejection of my RMA when my PSU is received by Cooler Master. These are the scratches: https://ibb.co/i50Ri5 https://ibb.co/fTqsO5 Any help appreciated!
  5. G650M PSU Failure

    Build Gigabyte Z170MX-Gaming 5 MB Intel Core i5-6500 CPU Corsair Vengeance LPX DDR4 16GB RAM SanDisk PLUS 240GB SSD Cooler Master G650M PSU (bought new around May/June of 2015) 2x Western Digital 7200RPM 1 TB 2x top 120MM Fans 1x front 240MM fan 1x rear 120MM fan AeroCool DS Case My PSU seems to have failed (in bold above), and I was wondering if anyone else has experienced failure with this specific PSU? On a whim I decided to stop off at Best Buy and bought a new Corsair CX750 PSU, and my PC is now running great (it would randomly power off and reboot when under load with the Cooler Master PSU). I have an RMA in process for the G650M, but I've been reading a lot of negativity surrounding Cooler Masters RMA process, and am wondering if I should just keep the Corsair PSU I bought from Best Buy (it was $90 - Amazon wants $88 for it, so I figure not a bad deal)? My plan was to return the Corsair PSU to Best Buy since I can now confirm it's my PSU that was the issue, but I also don't want to wait around for several weeks to get a replacement PSU. Thoughts?
  6. I have build a few mining rigs (cryptocurrency mining) past months and on my last order on PSU's when I couldnt order my preffered brand I got my hands on 3 Coolermaster V850 units. I had only 1 in action so far since I'm waiting for a cable order from china but since my order arrived I'm about to scale up my mining operation. So my design right now is any z87motherboard I can get which supports more than 4 graphic cards, 2x PSU's (1000w+650w/850w-depending on gpu's), 5-6 GPU's - 280x, 290... Now since I was pleased with the stability of my first V850 I ordered 8x v850 gold psu's from a german seller who claimed he can deliver within a week. But this is where the problems come in. Since I only use z87 motherboards with i5/i7 motherboards so I can resell the gear easier and have a more stable and powerefficient plattform. I started running gameservers on the cpus since they only idle around. When I setup the only rig which is running a v850, the psu started to make weird electrical noises - sort of clicking. The affected machine specs: asus z87 pro i5 4670 3x r9 280x 8 gig ram samsung 840 pro ssd CM v850 I checked what I draw from the wall and it was 685 - 720 Watts (this value goes up and down because of cpu usage). I then swapped it for a 860watt psu from another brand and everything was fine. Now I tested the other 2 V850 and all did the same nose when going above 700 watts. The funny thing is that when i up the vddc on my gpus so I pull 750watts the v850 has no problem with that but when I use the cpu and reach 700watts its game over..the psu's cant deliver enough voltage and the thing starts clicking + the gpus wont get enough power. That confused me because I run a few psu's and each of them is running on its max, for example a 2x 280x rig with an older i7950 no ssd but hdd...powerdraw from the wall 612-635 watt on a 4 year old 650w PSU (also gold standard). Is there a problem or something I should know about the V850? Not single 12v rail? (I have only single rail psu's). Why is only the CM ones clicking under load? I tried 2x 290 @ 300 watt each + cpu game servers running - no problem. As soon as go 3x gpu (200watt each)it goes bananas. I planned to make 4 rigs running: 6x r9 280x-vapor-x powered by 2x v850 with an i7 running a css server or similar. Now I have doubts that its supposed to do the clicking. Any advice? Plz dont tell me I should have bought v1000's to be save....I tried but not available in the quantities I needed. I got 6 1000watt psu and with that I basically bought all the 1000 watt psu's which were gold/platinum in vienna.
  7. Halfway through October I came home to a Computer that would not boot, this normally would not have been an issue and I could have just replaced the PSU. But I'm a college student who recently suffered a financial crisis and can barely afford gas anymore. Now I immedietly mailed it out to CM's RMA department and they emailed me on Nov. 4th saying they recieved it. They also said it would be at most 7-10 buisness days before my replacement was shipped out. Well, Here I am on Nov. 19th and its been 11 buisness days. Not only that but I just got an email saying that my replacement "should" be shipped out sometime next week(That would be at max 17 buisness days!!). This support is unnacceptable. If I do not get my Replacement soon I will have to get a payday loan just to buy a replacement. And I can promise you Cooler Master. I will make sure that everyone who comes to me for advice when building their PC's gets a mouthfull on why you should never buy Cooler Master. I'm also off to issue my complaint with the BBB. You can also be certain that if i don't get my replacement soon ill be heading directly to my local "small claims court" to file a law suit. I am VERY displeased. EDIT: I have just filed my BBB complaint. It seems funny to me that you guys have an F rating with them. I expect someone to contact me and offer a resolution quickly. If not i'll be following up on my second promise by heading to my local small claims court.
  8. Hello all, I have an issue that's been driving mad ! For the past two weeks I've been getting random restarts on my system on both the previous OS win-10 and the current win 8.1 . I've did clean installs/reinstalls for both OS' multiple times, yet I still face the issue. I'm not familiar with it but I assume it could be related to my PSU cable or maybe the power outlet extension cable. But I'm not sure yet, so I came here. Hopefully with your help guys, I can narrow it down to something. Thanks
  9. RMA for Silent Pro GOLD 1000W

    Hello, I returned my product Silent Pro GOLD 1000W on December 21st. The RMA was accepted December 19th and somehow it sat at the warehouse for about 3 days while shipping said it had arrived earlier it was 'accepted' on the 31st. I have missed a lot of days of working because of this delay. I've done some research about the process of this RMA and so far for the past 2 years it seems cooler master has had warehouse delays. Is there a way to get a hold of someone quicker for this process I have a $3000 computer paperweight right now, and had I known it would take this long I'd buy a new one from a nearby electronics store. Please help, thanks. -Cameron Edit: Here's my RMA No. CUSUS1512178
  10. Noisy Fan G600 PSU

    Hi, I'm a bit desapointed by my new power supply G600W. The fan (supposed to be quiet) is really noisy compared to the rest of my configuration. That's why i was thinking about changing it. Does anyone have the exact specifications (rpm, CFM, voltage range...) of the fan mounted in the PSU to be able to find one with the closest spec. Found anything on the internet, except that it's a 120mm fan and most likely, it's a 2 pin fan with voltage control Thanks !
  11. Unable to RMA my PSU - Follow Up

    Hello, This post is a follow up to the topic http://community.coolermaster.com/index.php/topic/12271-unable-to-rma-my-psu-desperate-dont-buy-cm-if-outside-usa/ which is now locked. I wanted to confirm to the CM Moderator "Inferno Storm" that In fact I have a valid US Adress for returning the replacement to. I don't have plans for traveling the US anytime soon, so I would like to be contacted by the US team via email to proceeed with the RMA request directly, instead of waiting for the IT team to solve the portal problems. On a sidenote, I logged in to my CM fanzone account, and tried to check my support tickets to see If there was any progress on that front, and I receive the following error message (Screenshot Attached): An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full 204.14.234.101:4432 So, at this point I'ts completely damaged and I cant follow up with Fellini. Awaiting for response, Eduardo
  12. Hello First of all sorry for my bad english. I think my PSU Silent Pro M600 is dead, because absolutely nothing happens if I press the start button. No ventilator or HDD movement and no LEDs working. Every cable is properly attached, 20+4pin/4+4pin/power plug/case connectors/etc. Unfortunatly i have no option to test the mainboard/cpu/ram with another PSU. My Question: What happens if I request an RMA for a PSU and send it in that is actually not defect? Do I have to pay a fee or somethin like that? In the event that it is important: the shop where i buyed the PSU does no longer exist, so i have to contact CM directly. Thank you! Greetings from Vienna, Austria. Not so important: How do I change the Forum Display Name? It says in the CM fan zone "fail getting data".
  13. Hi, I recently bought a G550M, and am concerned with the noise the fan is making, as it is a lot louder than I expected it to be. I've attached a recording of the noise the fan is making PSU Fan Noise.mp3. Has anyone heard a sound like this before? I'm not sure what to do about it. Sounds to me that the fan might be hitting a cable inside the PSU, but I can't check without voiding the warranty. Help would be appreciated.
  14. OK so I learnt the hard way not to buy anything else from a local dealer here where I live on the Gold Coast of Australia. Just a Quick rundown on what the issue is. I built my PC from the Ground up and bought a CM series Case along with a Cooler mater 1200 Silent Pro PSU ( I figured they looked AWESOME together). anyway, Since Day one of the purchase I have heard sounds coming from the PSU which kind of sound like something it's arching inside the unit. Now the place I bought it from have told me there is nothing wrong with the unit and they didn't hear the sounds I hear almost daily. So I tried setting up the PC in a different room to see if it was something in room making that noise or the power outlet socket but I still hear the same sound. After hearing the sound the system will shut down after a few mins and I've had to live with this power supply since 2010. when I pointed out to the store that the unit was still under warranty they were very quick to say I was incorrect and that it was out of warranty. I know the unit has a 5 year warranty. So after talking to consumer affairs and fair trade here in Australia I'm still left with a PSU that plays up every 3-4 days. I clean the inner parts of the PC with a dust blower and make sure that all areas are done. Is there anyone there at Cooler Master that can help me with this issue?? I'm begging you guys for the LOVE of you products. If i need to replace the PSU, you can bet your last dollar that it will be replaced with nothing but a Cooler Master PSU.
  15. Hello everyone, I'm writing this post regarding my futile attempts to create a RMA request for my Silent Pro M70 PSU since october last year. The automated process doesn't work for me. At first, I didn't even have an "RMA Request Button". After a long customer service conversation taking several weeks, I finally had the mighty button on my CM control panel. But I still cannot RMA my PSU because I'm outside USA, and even if there's a country drop-down list, the state slate is blank and the system doesn't allow me to go further. The most frustrating part of the process is that while I try to not be annoying and letting the IT department work, the system simply closes my case without resolving it, so I need to constantly re-open it. At this point I already bought another PSU from other brand, but I really liked the CM product and still wish to see this issue addressed. Is there anyone on the Cooler Master staff who can take my case as a human and help me RMA my product without waiting six months for the portal to work, or at least declining to offer support for people outside USA, so I can assume that I lost my money and never buy a CM product again? The customer service log is attached to the post for review. My ticket number is 00050791 Note: I made a mistake and published this topic in the cases subforum, so I'm reposting it here
  16. Silencio 352 PSU

    If i insert a h100i in push intake in the front, and I move the 3.5" drive bay to the left mounting holes. What would be the new maximum length for the PSU?
  17. Requirement of New Gaming PSU

    Hi all, I think with the upcoming Nvidia GeForce 900 series, DDR 4 Memory kits and 5th gen Proccessors it's time Cooler Master to think of a new Gaming Power Supply unit. The GXII and GXII Pro series are above par PSUs for current gaming rigs, but when new hardware and technology arrives (which will be soon) these PSUs would be less efficient and at doing the job. and maybe power rating may also be too much to bear. Since new hardware're gonna be equipped with higher frequencies and smaller components they may need extra attention on power supply + they will consume less voltage and less power too. like GTX 780 which is replaced by 30% faster GTX 980, power requirment will go down from 200W to 170W DDR 4 RAM now only consume 1.2V instead of DDR 3 consuming 1.5V (1.65V max) etc. So thought of hearing what you think about on a new Gaming Power Supply unit, what do want it to be like, what specs do you expect and what faults Cooler Master should overcome from. Please Share your ideas Thank You.
  18. Hello all, I need some help quickly. I am changing my GPU and i want to get a EVGA 770 4Gb or a Gigabyte r9 290. They both state that a minimum of 600watts is needed but the 770 has that the 12v rail must be minimum of 42a. I have a CM Extreme Power Plus 600w PSU and i would like to know if any of you can say for sure that the 770 would work or not?