Search the Community

Showing results for tags 'octane'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Case Mod World Series 2017
    • Case Mod World Series 2017
  • Announcements and Giveaways
    • Announcements
    • Giveaways
    • CES & Computex
  • PC Building Guide
    • Reviews and Unboxing
    • Build Advice
    • Build Worklogs
  • Hardware
    • Cooling
    • Cases
    • Power Supplies
    • Peripherals
  • General Discussion
    • General Hardware
    • Overclocking
    • Game Zone
    • Product Suggestions
  • Modding
    • Mod Lounge
    • Mod Worklogs
    • Mod Contests

Calendars

  • Community Calendar

Found 5 results

  1. CM storm octane

    Hello everyone, I recently got the cm storm octane gaming gear combo. After 2 days the mousewheel started squeaking, I find this very annoying I can not find a way to open the mouse, so can anyone help me to fix this? Thanks, Boyd
  2. Cm Octane Mouse Light problem

    So basically i turned on my pc today and noticed that only my left click light is working... Checked the cable, usb port, and drivers.. nothing seems to work.. What happens is that right light doesn't work at all, then it randomly turns on for few seconds, then starts to flickering and turns off again, and that just keeps repeating. I have mouse and keyboard for about 8months [images-on/flickering/off]
  3. So basically, I've had my Octane KB + Mouse for just over 6 months now and it's been fine. But all of a sudden it stopped working. Not a single key works, the LEDs are on, kb lock is OFF. Please help, the cm my product(s) system isn't working either.
  4. CM STORM OCTANE Software ?

    Is there any Software for CM storm Octane , to set macros , media key , and maybe custom DPI ?
  5. Hi I have a problem with my octane keyboard. I've only 3 colors : blue, red, purple and off. But the mouse have the 7 colors. I tried to connect on other pc but it did nothing. i bought this keyboard with this problem, so is it a manufacturing problem? or upon delivery, my pc or other? My PC : HP p6-2475ef windows 10 Please help me (sorry for my english, i'm french )