Search the Community

Showing results for tags 'not working after a 6 days unpowered'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Case Mod World Series 2017
    • Case Mod World Series 2017
  • Announcements and Giveaways
    • Announcements
    • Giveaways
    • CES & Computex
  • PC Building Guide
    • Reviews and Unboxing
    • Build Advice
    • Build Worklogs
  • Hardware
    • Cooling
    • Cases
    • Power Supplies
    • Peripherals
  • General Discussion
    • General Hardware
    • Overclocking
    • Game Zone
    • Product Suggestions
  • Modding
    • Mod Lounge
    • Mod Worklogs
    • Mod Contests

Calendars

  • Community Calendar

Found 1 result

  1. POwer supply Issue

    Good day Sir, I own a Cooler master 850W , product number : RS-850-ESBA . Last week on 28.08.2017 I went on holiday for 6 days so I removed the power cord from the power supply so nothing could happen while I was gone. I know that the power supply has a power failure protection and when you put the cord back on it takes a while for it to start. But it has been more than 20 hours since I have put the cord in the computer and it still won't start. The red led from the back of the power supply is not lightning . I know it has power cuz i put my hand inside and it almost electrecuted me. The power supply worked perfectly before so I don't really know what is the problem. Does it calculate the time it was off ? And by assumption now I will have to wait for 7 days for it to power back on ? Best requards, Ichim Andrei Hope to hear from you soon .