Search the Community

Showing results for tags 'microphone'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Announcements and Giveaways
    • Announcements
    • Giveaways
    • CES & Computex
  • PC Building Guide
    • Reviews and Unboxing
    • Build Advice
    • Build Worklogs
  • Hardware
    • Cooling
    • Cases
    • Power Supplies
    • Peripherals
  • General Discussion
    • General Hardware
    • Overclocking
    • Game Zone
    • Product Suggestions
  • Modding
    • Mod Lounge
    • Mod Worklogs
    • Mod Contests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Suddenly the microphone on my CM Ceres 300 headset, which previously worked just as it should, no longer works at all - I've now tested it on three computers, one a desktop running Linux Mint 18.3, and a desktop and laptop, both running Windows 10 v 1709. No problem with the headphones, which work quite well on all these boxes, but I can't get the microphone to work on any of them. I tried to register the product in order to file a ticket, but unfortunately the sticker with the serial number, which seems to have been attached to the back of the volume control, has fallen off, rendering it impossible for me to find that number. I do have, however, a copy of of the purchase receipt, which shows my order number and the retailer's product number - but alas, not the serial number - which I should be happy to upload in order to demonstrate authenticity..... I have note that several other users have posted about the same problem, which doesn't seem to be uncommon for this product ; are there any general recommendations which might help me troubleshoot this situation ? Henri
  2. Hello all I really really need help, i have the sirus cm storm 5.1 usb headset and i have encountered quite a frustrating problem and would really like some help in getting it fixed. To start off with, all the components are fine, and work. the speakers work well, and the microphone works fine as well as all the mechanical parts that go along with it. my problem is that my mic and headphones love to alternate. Meaning that when my headphones are working correctly. then my microphone wont work. and vice versa... i game alot and use teamspeak alot so as you can imagine this is quite a problem. i have tried downloading both the latest drivers for the headset and for the motherboard sound. none have yet to fix the problem. please please i really need help or this may result in me having to waste good money on another headset . I run the latest Windows 8.1 Msi military class 3 i5 Nvidia gtx 660 8gig ram etc etc i dont think this will have to do with my pc specs... anyway all help is greatly appreciated and i hope to hear from people soon