Search the Community

Showing results for tags 'masterliquid 360'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Announcements and Giveaways
    • Announcements
    • Giveaways
    • CES & Computex
  • PC Building Guide
    • Reviews and Unboxing
    • Build Advice
    • Build Worklogs
  • Hardware
    • Cooling
    • Cases
    • Power Supplies
    • Peripherals
  • General Discussion
    • General Hardware
    • Overclocking
    • Game Zone
    • Product Suggestions
  • Modding
    • Mod Lounge
    • Mod Worklogs
    • Mod Contests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Issue: LED lights not turning on, however all the LED's on the Fans work perfectly as they should. I Have everything wired and hooked in accordingly. Has anyone else had this issue with this product line? Including the ML120 & ML240 Series? Is it something I need to RMA or could I have simply wired it in wrong? I've plugged the LED lights that were running the other fan lights to see if that would fix the issue but the LED's on the Pump Housing itself wont even come on. I don't think this is an issue with the MB due to it being all plugged into the CM control module they send with the ML360R Parts List: Gigabyte Aorus Pro Wifi z390 Cooler Master MB530P Case w/ 6 ARBG Cooler Master 120mm Fans (3 Came with the case and 3 came with the liquid cooler)
  2. I have purchased this liquid cooler this month in February. At first when I have turned it on it did not do this but after a couple of days past, I'm hear gurgling / bubble sounds coming out from the CPU pump. I read some forums online this could be due to air coming through, however I am unsure if this is fixable or or entirely faulty at all. And if I should request an exchange if this is a faulty product. I would appreciate if you could advise me on this technical problem. I have provided you a YouTube link to the video I recorded the sound. Please put your Audio to relatively high so you can hear it. Video Link: https://youtu.be/P9DYX1xnMa8 Hope to hear from you soon. Many Thanks, Kind Regards.