Search the Community

Showing results for tags 'Silent Pro'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Campaign
    • Case Mod World Series 2019
  • Announcements and Giveaways
    • Announcements
    • Giveaways
    • CES & Computex
  • PC Building Guide
    • Reviews and Unboxing
    • Build Advice
    • Build Worklogs
  • Hardware
    • Cooling
    • Cases
    • Power Supplies
    • Peripherals
  • General Discussion
    • General Hardware
    • Overclocking
    • Game Zone
    • Product Suggestions
  • Modding
    • Mod Lounge
    • Mod Worklogs
    • Mod Contests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Hello First of all sorry for my bad english. I think my PSU Silent Pro M600 is dead, because absolutely nothing happens if I press the start button. No ventilator or HDD movement and no LEDs working. Every cable is properly attached, 20+4pin/4+4pin/power plug/case connectors/etc. Unfortunatly i have no option to test the mainboard/cpu/ram with another PSU. My Question: What happens if I request an RMA for a PSU and send it in that is actually not defect? Do I have to pay a fee or somethin like that? In the event that it is important: the shop where i buyed the PSU does no longer exist, so i have to contact CM directly. Thank you! Greetings from Vienna, Austria. Not so important: How do I change the Forum Display Name? It says in the CM fan zone "fail getting data".
  2. Hello everyone, I'm writing this post regarding my futile attempts to create a RMA request for my Silent Pro M70 PSU since october last year. The automated process doesn't work for me. At first, I didn't even have an "RMA Request Button". After a long customer service conversation taking several weeks, I finally had the mighty button on my CM control panel. But I still cannot RMA my PSU because I'm outside USA, and even if there's a country drop-down list, the state slate is blank and the system doesn't allow me to go further. The most frustrating part of the process is that while I try to not be annoying and letting the IT department work, the system simply closes my case without resolving it, so I need to constantly re-open it. At this point I already bought another PSU from other brand, but I really liked the CM product and still wish to see this issue addressed. Is there anyone on the Cooler Master staff who can take my case as a human and help me RMA my product without waiting six months for the portal to work, or at least declining to offer support for people outside USA, so I can assume that I lost my money and never buy a CM product again? The customer service log is attached to the post for review. My ticket number is 00050791 Note: I made a mistake and published this topic in the cases subforum, so I'm reposting it here