Search the Community

Showing results for tags '5.1'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Campaign
    • Case Mod World Series 2019
  • Announcements and Giveaways
    • Announcements
    • Giveaways
    • CES & Computex
  • PC Building Guide
    • Reviews and Unboxing
    • Build Advice
    • Build Worklogs
  • Hardware
    • Cooling
    • Cases
    • Power Supplies
    • Peripherals
  • General Discussion
    • General Hardware
    • Overclocking
    • Game Zone
    • Product Suggestions
  • Modding
    • Mod Lounge
    • Mod Worklogs
    • Mod Contests

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Good day, I just purchased the above mentioned headset and found that the minute usb is plugged in the headphones get extremely irritating buzzing/static/white noise. I tried connecting the headset directly using the 3.5mm jacks(without using the "puck") and it worked fine, no noise...until I once again plugged in the usb which comes with the jacks and the noise starts again. PSU is a Corsair H1100 (I think...) which is plugged into a surge protector. I did try plugging the headset into a laptop and the noise persisted...even if the power cord is out... As long as an USB is connected, the noise is there. Any help would be greatly appreciated.
  2. Hello all I really really need help, i have the sirus cm storm 5.1 usb headset and i have encountered quite a frustrating problem and would really like some help in getting it fixed. To start off with, all the components are fine, and work. the speakers work well, and the microphone works fine as well as all the mechanical parts that go along with it. my problem is that my mic and headphones love to alternate. Meaning that when my headphones are working correctly. then my microphone wont work. and vice versa... i game alot and use teamspeak alot so as you can imagine this is quite a problem. i have tried downloading both the latest drivers for the headset and for the motherboard sound. none have yet to fix the problem. please please i really need help or this may result in me having to waste good money on another headset . I run the latest Windows 8.1 Msi military class 3 i5 Nvidia gtx 660 8gig ram etc etc i dont think this will have to do with my pc specs... anyway all help is greatly appreciated and i hope to hear from people soon