KingFatty

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About KingFatty

  • Rank
    LED Head

Recent Profile Visitors

146 profile views
  1. Yes, I have this issue too. I have been putting up with it by sleeping my computer, instead of shutting it down. At first the problem will happen in windows, but eventually it will be bad in BIOS too. Every time you unplug and replug the USB, the keyboard is fine. If you get any advice on how to solve this issue, please share here. I believe it's a problem with the keyboard being bad, so make sure to register it for warranty/RMA when it continues getting worse. But, Coolermaster will challenge you to jump through hoops to prove your keyboard is bad before they will help you. So you'll need another computer you can use to duplicate the issue. I think this is unfair, because I don't care if the keyboard works on another computer, *I BOUGHT THE KEYBOARD TO WORK WITH MY EXISTING COMPUTER, NOT MY BACKUP COMPUTER*
  2. Darn, spoke too soon - I still suffer from the problem. I let the computer sit powered off for more than 24 hours, and when I booted up, the keyboard was unresponsive again, after Windows loaded. This is with the USB Legacy setting at "auto" instead of "enabled." I could reboot and the keyboard worked in BIOS, and this time I exited BIOS and the computer continued to boot up Windows, but the funny thing was the keyboard was partially responsive at that point, and I could hit a few keys to where the keyboard became responsive again as though I had unplugged and replugged it. So that partial success is after exiting out of BIOS and going to windows, but not going from a straight boot into windows.
  3. Thanks. With solution method 3) above, does that turn on the LED *before* you've logged in? Or do you have to enter your login password successfully first, before the keyboard will light up? I ask because I wonder if the keyboard will be dark while you are trying to enter your password?
  4. Hello, This looks great, but can you advise on my problem? I follow the guide for the first option, launching Regedit and changing the value for all users (change the InitialKeyboardIndicators from "2" to "6". But, when I reboot the computer, the value is reset back to 2! When I run regedit again and look at the value, it's 2 again, and it just overwrites the 6 back to a 2 each time I change it and restart windows. How can I make my change stick? Is there something else overwriting the 6 back to a 2, such as another registry entry somewhere else? Also note, under your instructions for changing for the current user, I notice the oddness that the value for InitialKeyboardIndicators is not set initially to a 2 like you'd expect (and how the above setting is initially set), but instead this one has a weird value of 2147483648. Could that have something to do with why the computer resets the setting for all users back to a 2, despite my changing it to a 6? Do I have to change both values to a 6? I only tried changing the entry for all users as instructed under the first bullet point above, and did not change the values for both regedit entries. Thanks!
  5. I'm continuing to test, but after exhausting other options such as different USB ports, the solution may be as follows to enable support for the CM Storm Devastator under windows for my MSI Z97 Gaming 5 motherboard under the newest BIOS (dated June 01 2015): The BIOS setting "Legacy USB Support" under USB Configuration should *not* be set to its default value of "Enabled" for this motherboard. Instead, the BIOS setting should be changed to "Auto" for this motherboard, the MSI Z97 Gaming 5. The "Auto" setting allows the system to automatically detect if any USB device is connected and enables or disables the legacy USB support. This appears to allow the CM Storm Devastator to continue working, unlike the "Enabled" setting which merely enables USB support for legacy operating systems that do not support USB. After changing this setting, I tried rebooting multiple times, and also powering off (including powering off and removing the power completely by turning off the power supply switch and then cycling the computer power switch to fully drain power), leaving the computer off for an hour, and still the keyboard consistently works after changing the BIOS setting. I'll update if it stops working, but it was so successful that I think you may want to consider updating the other posts to suggest trying this "auto" setting for Legacy USB Support (instead of "enabled") for MSI motherboards. maybe it would even work for other keybaords like the QuickFire Rapid-i, because seemingly it's a conflict with the way MSI motherboard handles legacy devices and CM keyboards?
  6. Hello, I have a CM Storm Devastator that works fine in BIOS or during computer bootup, but when Windows 8.1 x64 loads the login screen, the keyboard becomes unresponsive. I can solve the issue if I unplug the keyboard and plug it back in, but this is annoying. I can also get the keyboard to stay recognized if I hold down the spacebar button constantly from bootup until windows loads, which is very strange that it could work but it does (perhaps other keys would work too, but I've only tried the spacebar so far). I've also tried troubleshooting by using different USB ports, and also I tried uninstalling the Intel® USB 3.0 eXtensible Host Controller Driver. Uninstalling that driver actually worked because when I rebooted, the keyboard worked fine in windows 8.1, but then windows just reinstalled that driver during my windows session so after my next bootup the same issue resurfaced, where the keyboard stops working upon Windows loading. Any tricks or work-arounds to overcome this issue of the keyboard going dead when windows loads? I first noticed this consistent behavior after installing the latest BIOS update to my motherboard (MSI Z97 Gaming-5). I am not sure when the next motherboard BIOS will be released but plan to install it whenever it comes out to see if the problem goes away, but that could be months and I was hoping there was some configuration in windows I could use now to keep the keyboard alive when windows loads (without having to hold down the spacebar after booting up, or replugging the USB plug of the keyboard). Thanks!