Pack Man

Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Pack Man

  • Rank
    LED Head

Recent Profile Visitors

118 profile views
  1. Firmware v.119 is old. New version can be found on this address: http://gaming.coolermaster.com/en/products/keyboards/rapid-i/ Once there click on DOWNLOADS.
  2. FIX works for me. No problems on Asus Sabertooth 990fx r2.0 motherboard. When I am using M1, M2, … profiles and want to switch back to MODE I press FN + MODE and it exits M1, M2,… but instead of returning to the MODE I was using before I started M1, M2,… it goes to the next MODE in line. Then I have to circle through all modes to get to the MODE I was on before I enabled Backlighting profile mode (M1, M2,…). Can you please do something about this? Is there a beather way to exit Backlighting profile mode? Another (TO ME) logical way of exiting Backlighting profile mode (M1, M2,…) would be to press FN + M1, M2,… and IF Backlighting profile mode is ON then EXIT if not ENABLE.
  3. I love this keyboard. But if I had a chance to change anything on it in order to improve this product it I would do the following: Make management / config software. Customizing, firmware update, firmware info... How do you people know what firmware is in your keyboard? I don’t like that lights are on MAX on Caps Lock, M1, M2, M3, M4,... keys. I understand the decision to do it this way but having an option to customize this would be nice. How do you exit Backlighting profile mode (M1, M2,....)? I usually click fn + mode (f4) and then it moves me from M1 or M2... to mode. But not to the mode I was on before I enabled Backlighting profile mode. It returns me to the next mode in line. Then I have to circle through all modes to get to the mode I was on before I enabled Backlighting profile mode. This can probable be fixed in the firmware. Maybe there is a bather way to switch between Backlighting profiles and Mode? Again I understand the decision to leave M1, M2, M3 and M4 lights ON when Backlighting profile is on. But I don’t like it. If only there was a way to customize this.