AL

Members
  • Content Count

    3
  • Joined

  • Last visited

Posts posted by AL


  1. Good news! Called up the Cooler Master support line and got through to someone almost instantly. Here's what I know now:

     

    - They're dealing with a backlog of tickets from over the holidays (hence the support delays).

     

    - They're aware of the LED issue though I think it's still too early for them to know what the exact cause/solution might be.

     

    - They're sending me a replacement top panel, and if the problem comes up again they said they can send another (though ideally after they've fixed whatever is causing this to begin with, because at that point it's likely a manufacturing defect).


  2. Nothing yet (opened the ticket on Jan 9, so coming up on a week).

     

    Did the whole Cooler Master team pack up and go to CES or something? Or is it normal for tickets to take a while to get a response?


  3. As others have reported, the C700M appears to have some kind of issue talking to its LED strips (the two on top in my particular case). When powered on about 70-80% of the strips appear to be dead but will randomly come back to life over time -- albeit with whatever color it "saw" last, which tells me they're still able to partially communicate with the LED controller, but it's sporadic at best.

     

    Anyway, opened a ticket a few days ago but I have yet to hear anything from Cooler Master so I figured I'd throw my hat in with everyone else having this issue. Kind of a disappointment considering the cost of the case, but I'd be content with receiving replacement parts (and installation instructions) since I know these things happen.

    c700m.jpg