Dude Guyman

Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Dude Guyman

  • Rank
    LED Head

Profile Information

  • Gender
    Male

Recent Profile Visitors

375 profile views
  1. I figured I should start a new thread for this on Linux since some may not look in the "Windows" thread. This is what I have learned about getting the backlights to come on with Ubuntu based Linux distros and Manjaro (mainly Mint Xfce 17.2, 17.3, Xubuntu) that for whatever reason have Scroll Lock disabled. Change "leafpad" to whatever your text editor is (gedit? mousepad?): 1. - Temporary (like when you are first installing Linux and my not have your text editor or gksu installed yet): terminal command > xmodmap -e 'add mod3 = Scroll_Lock' 2. - Permanent method 1 (best way in my experience, adjust if needed for your keyboard local, may not be "us" file?): gksudo leafpad /usr/share/X11/xkb/symbols/us Add the following line at the end of the .../xkb/symbols/us "basic" section. modifier_map Mod3 { Scroll_Lock }; example of the relevant "basic" section lines from my "us file"... key <BKSL> { [ backslash, bar ] }; modifier_map Mod3 { Scroll_Lock }; }; clear cache: sudo rm -f /var/lib/xkb/* reboot 3. - Permanent method 2: Create .Xmodmap in home directory containing this line: add mod3 = Scroll_Lock Create /etc/X11/Xmodmap containing the same line: add mod3 = Scroll_Lock Commands to do it easily. Run the command and paste in: add mod3 = Scroll_Lock leafpad ~/.Xmodmap gksudo leafpad /etc/X11/Xmodmap
  2. The gpedit.msc method worked for me on Windows 7 Pro x64. The registry methods failed, same as others. Thanks. If your scroll lock key does not work in Linux (Mint 17.3 and probably most others): Temporary: terminal command xmodmap -e 'add mod3 = Scroll_Lock' Permanent: Create .Xmodmap in home directory containing this line: add mod3 = Scroll_Lock Create /etc/X11/Xmodmap containing the same line: add mod3 = Scroll_Lock Commands to do it easily. Run the command and paste in: add mod3 = Scroll_Lock Change "leafpad" to whatever your text editor is (gedit? mousepad?): leafpad ~/.Xmodmap gksudo leafpad /etc/X11/Xmodmap
  3. Here's one for the Linux section: Problem: In Linux Mint 17.2 Xfce (probably all Ubuntu based Linux distros) the Scroll Lock key is broken/disabled so you can not turn on the back lighting. Fix: Temporary: enter the following terminal command xmodmap -e 'add mod3 = Scroll_Lock' Permanent (this only worked sometimes for me): 1. Create a file/document named .Xmodmap in your home directory containing this line: add mod3 = Scroll_Lock 2. Create /etc/X11/Xmodmap containing the same: add mod3 = Scroll_Lock Terminal commands to do it (replace "text-editor" with whatever you use. mousepad, gedit, leafpad?): text-editor ~/.Xmodmap gksudo text-editor /etc/X11/Xmodmap 3. Reboot. I had better luck with this method: gksudo leafpad /usr/share/X11/xkb/symbols/us Add the following line in the xkb_symbols "basic" section at the bottom. "modifier_map Mod3 { Scroll_Lock };" key <BKSL> { [ backslash, bar ] }; modifier_map Mod3 { Scroll_Lock }; }; clear cache: sudo rm -f /var/lib/xkb/* reboot